Release Critical bugs

ID Package Title Severity
#866413 aafigure aafigure: depends on obsolete python-imaging (replace with python3-pil or python-pil) serious
#887529 aiohttp-cors aiohttp-cors FTBFS: test errors serious
#904358 aiozmq python3-aiozmq: fails to install with python 3.7 serious
#907871 alembic python3-alembic,python-alembic: ships /usr/lib/python*/dist-packages/.pytest_cache/v/cache/nodeids serious
#892988 autokey autokey-gtk: does not start grave
#874367 awscli awscli: 'AWSHTTPSConnection' object has no attribute 'ssl_context' serious
#907298 awscli CVE-2018-15869 grave
#903519 backblaze-b2 backblaze-b2 FTBFS with Python 3.7 as supported version serious
#903579 basemap basemap: Generate _geoslib.c with Cython 0.28.2 for Python 3.7 transition serious
#891087 beautifulsoup beautifulsoup has been replaced by bs4 serious
#868872 cairocffi cairocffi FTBFS: test failure serious
#905367 cccolutils cccolutils: FTBFS in sid serious
#902900 celery python3-celery: python3-celery fails to install with Python 3.7 serious
#902222 celery-haystack celery-haystack: depends on django-celery-transactions which has been requested to be removed serious
#902456 cf-python cf-python: FTBFS in buster/sid (AttributeError: 'module' object has no attribute 'netcdftime') serious
#822586 cherrytree cherrytree: depends on python-gtksourceview2 which is deprecated serious
#867787 cherrytree cherrytree: Changes sometimes not saved grave
#908687 cookiecutter cookiecutter FTBFS with python-click 6.7+git20180829-1 serious
#755584 django-adminaudit django-adminaudit: Please ensure it works with Django 1.7 serious
#755586 django-app-plugins django-app-plugins: Please ensure it works with Django 1.7 serious
#896259 django-app-plugins python-django-app-plugins: app_plugins fails to import serious
#881197 django-celery-transactions django-celery-transactions FTBFS with celery 4.1.0-1 serious
#896268 django-celery-transactions python3-django-celery-transactions: djcelery_transactions fails to import serious
#896311 django-celery-transactions python-django-celery-transactions: djcelery_transactions fails to import serious
#865293 djangocms-admin-style djangocms-admin-style FTBFS with Django 1.11 serious
#828647 django-floppyforms FTBFS under Django 1.10 serious
#848073 django-macaddress python3-django-macaddress: Compatibility of django-macaddress with django 1.10 in stretch serious
#833828 django-markupfield Migrations of stable's python3-django-markupfield (1.2.1) do not work with stable's django version (1.7.x). serious
#755605 django-threaded-multihost django-threaded-multihost: Please ensure it works with Django 1.7 serious
#802050 doctrine-sphinx-theme doctrine-sphinx-theme: please migrate to Bootstrap 3.x serious
#821123 doctrine-sphinx-theme Useless in Debian serious
#904382 doublex python3-doublex: fails to install with Python 3.7 serious
#865851 drf-extensions drf-extensions FTBFS with Django 1.11 serious
#898800 foolscap foolscap: FTBFS against openssl 1.1.1 serious
#906215 foolscap foolscap autopkgtest needs update for new version of twisted serious
#787614 gmail-notify [src:gmail-notify] Some sources are not included in your package serious
#881289 guessit guessit FTBFS: NoMatches: No guessit.transformer extensions found serious
#896202 guessit python-guessit: guessit fails to import serious
#896282 guessit python3-guessit: guessit fails to import serious
#896322 guessit python3-subliminal: subliminal fails to import serious
#896346 guessit python-guessit: guessit fails to import serious
#896759 gui-ufw gui-ufw: missing build dependency on python3-distutils serious
#897503 hg-git hg-git: FTBFS: + cat: hgrepo2/.hgtags: No such file or directory serious
#899317 hg-git mercurial-git: Breaks with python-dulwich 19.1 serious
#855908 hiro hiro: FTBFS: test_segment_not_complete_error [...] AssertionError: False is not true serious
#866432 ibid ibid: depends on obsolete python-imaging (replace with python3-pil or python-pil) serious
#891095 ibid ibid: python-beautifulsoup is replaced with python-bs4 serious
#902471 ipywidgets ipywidgets: FTBFS in buster/sid (error TS2352: Type 'HTMLButtonElement' cannot be converted to type 'HTMLInputElement') serious
#907873 jaraco.itertools python3-jaraco.itertools,python-jaraco.itertools: ships /usr/lib/python*/dist-packages/.pytest_cache/v/cache/nodeids serious
#897106 jpylyzer jpylyzer FTBFS with pandoc 2.1.2 serious
#866436 keysync keysync: depends on obsolete python-imaging (replace with python3-pil or python-pil) serious
#868773 khal khal FTBFS: AssertionError: assert not OSError(6, 'No such device or address') serious
#908497 khal khal FTBFS with python-dateutil 2.7.3-1 serious
#873501 kivy kivy FTBFS with Cython 0.26 serious
#884997 lottanzb lottanzb: Please don't recommend python-gnome2 serious
#897658 m2crypto m2crypto: FTBFS against openssl 1.1.1 serious
#902378 mugshot mugshot: fails to start: ImportError: No module named 'gi' serious
#902638 mwic mwic: FTBFS in buster/sid (dh: unable to load addon python3) serious
#896250 napalm-base python-napalm-base: napalm_base fails to import serious
#896412 napalm-base python-napalm-eos: napalm_eos fails to import serious
#896280 napalm-fortios python-napalm-fortios: napalm_fortios fails to import serious
#896260 napalm-ios python-napalm-ios: napalm_ios fails to import serious
#896229 napalm-iosxr python-napalm-iosxr: napalm_iosxr fails to import serious
#851420 openteacher openteacher: Requires no longer provided python-qt4 QtWebKit module grave
#879034 pdfshuffler pdfshuffler: port to gir1.2-poppler-0.18 serious
#906701 peewee peewee FTBFS with Python 3.7 as supported version serious
#908700 pep8 pep8: FTBFS (test_checkers_testsuite fails) serious
#866449 phatch phatch: depends on obsolete python-imaging (replace with python3-pil or python-pil) serious
#866453 pkpgcounter pkpgcounter: depends on obsolete python-imaging (replace with python3-pil or python-pil) serious
#903363 plainbox plainbox: FTBFS in buster/sid (dh_installman: Cannot find "build/sphinx/man/CHECKBOX_DATA.7") serious
#824347 planet-venus fails in jessie with "django.core.exceptions.AppRegistryNotReady: Apps aren't loaded yet." grave
#845987 planet-venus planet-venus: Fails with html5lib 0.999999999-1 serious
#891096 planet-venus planet-venus: python-beautifulsoup is replaced with python-bs4 serious
#896624 prospector FTBFS with sphinx 1.7.2: exception: cannot import name 'Directive' serious
#881565 pyacoustid python-acoustid: incompatible with python3 (fix availble upstream) serious
#881566 pyacoustid python-acoustid: incompatible/broken on Python 3 (fix available upstream) serious
#866457 pycaptcha pycaptcha: depends on obsolete python-imaging (replace with python3-pil or python-pil) serious
#904876 pycodestyle pycodestyle fails one test case when running with Python 3.7 serious
#902035 pygame pygame FTBFS on ppc64el, testsuite failure. serious
#902036 pygame pygame FTBFS on s390x, testsuite failure. serious
#905985 pygame pygame FTBFS with python 3.7 serious
#904491 pylama python3-pylama: fails to install with Python 3.7 serious
#909490 pylint pylint: doesn't support Python 3.7 serious
#888157 pylint-celery pylint-celery FTBFS and Debci failure: ImportError: cannot import name make_tests serious
#884220 pylint-common pylint-common FTBFS: ImportError: cannot import name make_tests serious
#896248 pylint-flask python3-pylint-flask: pylint_flask fails to import serious
#896287 pylint-flask python-pylint-flask: pylint_flask fails to import serious
#899663 pylirc pylirc: Invalid maintainer address pkg-lirc-maint@lists.alioth.debian.org serious
#891670 pymssql pymssql FTBFS with freetds-dev 1.00.82-2 serious
#880093 pyotherside pyotherside 1.2 cannot convert QVariant to QJSValue with qt5.7 serious
#890646 py-postgresql python3-postgresql: Connect to postgresql-Database Version 10 (buster) fails with an python error grave
#815393 pypuppetdb pypuppetdb: FTBFS: E: pybuild pybuild:274: test: plugin custom failed with: exit code=5: python2.7 -m pytest -m unit serious
#812138 pyqwt3d pyqwt3d: FTBFS with GCC 6: narrowing conversion serious
#875116 pyqwt3d [pyqwt3d] Future Qt4 removal from Buster serious
#906555 pyrit pyrit: FTBFS in buster/sid (failing tests) serious
#792197 pysdl2 FTBFS: SDLTimerTest.test_SDL_GetTicks fails, others flaky serious
#784512 pyside [pyside] Qt4's WebKit removal serious
#892620 pytest-bdd pytest-bdd FTBFS with pytest 3.3.2-2 serious
#894705 pytest-instafail pytest-instafail's autopkg tests fail with pytest 3.3 serious
#894723 pytest-instafail pytest-instafail: testsuite and package broken? serious
#906400 pytest-qt pytest-qt: FTBFS in buster/sid (failing tests) serious
#896231 pytest-runner python-pytest-runner: ptr fails to import serious
#896428 pytest-runner python3-pytest-runner: ptr fails to import serious
#904247 pytest-sugar pytest-sugar: FTBFS and test failure with pytest 3.6 serious
#839608 python-application python-application: keep out of stretch for now serious
#894258 python-asgi-ipc python-asgi-ipc FTBFS with python3-msgpack 0.5.1 serious
#896382 python-asgi-ipc python3-asgi-ipc: asgi_ipc fails to import serious
#834917 python-async python-async: FTBFS on single CPU machines serious
#904492 python-async python3-async: fails to install with Python 3.7 serious
#857298 python-cassandra-driver python-cassandra-dbg is an empty package on hppa, m68k, mips, powerpc, powerpcspe, ppc64, s390x, and sparc64 grave
#909413 python-cffi cffi broke pyopencl ? serious
#891753 python-django python-django FTBFS: ERROR: test_load_empty_dir (migrations.test_loader.LoaderTests) serious
#755625 python-django-extdirect python-django-extdirect: Please ensure it works with Django 1.7 serious
#828669 python-django-mptt FTBFS under Django 1.10 serious
#752101 python-django-piston python-django-piston: Missing dependencies serious
#755649 python-django-threadedcomments python-django-threadedcomments: Please ensure it works with Django 1.7 serious
#801935 python-django-threadedcomments python-django-threadedcomments: Fails to build from source with Django 1.8 serious
#896352 python-django-threadedcomments python-django-threadedcomments: threadedcomments fails to import serious
#903609 python-eventlet python-eventlet FTBFS: test failures serious
#841552 python-feather-format python-feather-format: FTBFS: dh_auto_test: pybuild --test -i python{version} -p 2.7 returned exit code 13 serious
#868971 python-feather-format python-feather-format: FTBFS: feather/ext.cpp:28:20: fatal error: Python.h: No such file or directory serious
#896370 python-feather-format python-feather-format: feather fails to import serious
#904115 python-feather-format python3-feather-format: Uninstallable in unstable serious
#838638 python-googlecloudapis /usr/bin/python3-google-api-tools broken; missing several dependencies, does not work even after doing so grave
#902759 python-http-parser python-http-parser FTBFS with Python 3.7 serious
#908498 python-icalendar python-icalendar FTBFS with python-dateutil 2.7.3-1 serious
#875610 pythonmagick python-pythonmagick: Undefined symbol in python2.7 PythonMagick.x86_64-linux-gnu.so grave
#906402 python-mongoengine python-mongoengine: FTBFS in buster/sid (ModuleNotFoundError: No module named 'document') serious
#896657 python-pex pex fails to start grave
#884935 python-poppler python-popper: Don't release with buster serious
#827832 python-pytc python-pytc: FTBFS: /bin/sh: 3: pythonpython2.7-dbg: not found serious
#892625 python-raven python-raven FTBFS: TypeError: _log() got an unexpected keyword argument 'blah' serious
#896344 python-raven python-raven: raven fails to import serious
#781813 python-restkit python-restkit: CVE-2015-2674: incorrect SSL/TLS certificate validation grave
#906198 python-scipy [python-scipy] causes FTBFS on of imexam: scipy.optimize.leastsq fails on S390x serious
#891725 python-scrapy python-scrapy FTBFS: test failures serious
#843353 python-shade python3-shade: fails to upgrade from 'testing' - trying to overwrite /usr/bin/shade-inventory serious
#882551 python-shade python-shade FTBFS: test failures serious
#904642 python-signaller python3-signaller: fails to install with Python 3.7 serious
#883763 python-social-auth python-social-auth: Includes "site/css/site.css" listed in Files-Excluded header serious
#854542 python-stopit python-stopit: Non-determistically FTBFS due to unreliable timing in tests serious
#896297 python-stopit python-stopit: stopit fails to import serious
#896319 python-stopit python3-stopit: stopit fails to import serious
#894234 python-testing.mysqld python-testing.mysqld FTBFS with python-pymysql 0.8.0-1 serious
#866471 python-trml2pdf python-trml2pdf: depends on obsolete python-imaging (replace with python3-pil or python-pil) serious
#891102 python-tvrage python-tvrage: python-beautifulsoup is replaced with python-bs4 serious
#907662 python-tvrage python-tvrage: useless after TVRage.com shut down? grave
#904650 python-websockets python3-websockets: fails to install with Python 3.7 serious
#897489 python-whoosh python-whoosh: FTBFS: dh_auto_test: pybuild --test --test-pytest -i python{version} -p 3.6 returned exit code 13 serious
#903529 python-ws4py python3-ws4py fails to install with Python 3.7 as supported version grave
#896489 python-zxcvbn python-zxcvbn,python3-zxcvbn: both ship /usr/bin/zxcvbn serious
#880497 pytimechart pytimechart: missing dependencies grave
#877202 pyxdg pyxdg FTBFS and Debci failure: ERROR: test_validate_icon_theme (test-icon.IconThemeTest) serious
#907422 pyyaml python-yaml-dbg is empty serious
#822020 quixote quixote: Build arch:all+arch:any but is missing build-{arch,indep} targets serious
#907807 requests After upgrading to OpenSSL 1.1.1, many sites are unreachable serious
#813340 rhythmbox-ampache rhythmbox-ampache: KeyError when selecting the tab grave
#908941 rpyc rpyc FTBFS: test_registry.TestUdpRegistry failures serious
#896331 simpleparse python-simpleparse-mxtexttools: simpleparse.stt.TextTools.mxTextTools fails to import serious
#905222 spambayes spambayes: several binaries fail to run: ImportError: cannot import name asyncore serious
#896327 sphinxcontrib-rubydomain python-sphinxcontrib.rubydomain: sphinxcontrib.rubydomain fails to import serious
#896395 sphinxcontrib-rubydomain python3-sphinxcontrib.rubydomain: sphinxcontrib.rubydomain fails to import serious
#881264 subliminal subliminal: FTBFS and Debci failure with stevedore 1.25.0-2 serious
#906320 texext texext: FTBFS: test failures serious
#891612 thumbor thumbor: uninstallable after python-imaging removal serious
#889277 trac-privateticketsplugin trac-privatetickets is empty grave
#904648 tweepy python3-tweepy: fails to install with Python 3.7 serious
#904649 txfixtures python3-txfixtures: fails to install with Python 3.7 serious
#903989 vcr.py vcr.py: autopkgtest needs update for python3.7 in supported versions serious
#904657 voltron voltron: fails to install with Python 3.7 serious
#891105 webcheck webcheck: python-beautifulsoup is replaced with python-bs4 serious
#908277 wtforms wtforms: FTBFS (failing tests) serious
#904748 zktop zktop: missing dependency on python3-pkg-resources serious

Bugs needing help

ID Package Title Severity
#897516 cram cram: FTBFS: tests failed important
#784512 pyside [pyside] Qt4's WebKit removal serious
#581723 python-django-registration python-django-registration: tests fail whith custom registration form normal
#657301 python-docutils rst.el doesn't work with XEmacs: Invalid regexp: "Invalid preceding regular expression" important
#343675 trac Document deploy and upgrade process normal
#560022 trac pysqlite2.dbapi2.ProgrammingError: Cannot operate on a closed cursor normal

Bugs with usertag debian-python@lists.debian.org

ID Package Title Severity
#902900 celery python3-celery: python3-celery fails to install with Python 3.7 serious
#883157 libapache2-mod-python libapache2-mod-python: Please support for Python3 normal
#862434 mod-wsgi mod-wsgi only supports the default python/python3 version normal
#585305 myghty python-myghty: Python string exceptions no more allowed in Python 2.6 minor
#585306 myghtyutils python-myghtyutils: Python string exceptions no more allowed in Python 2.6 minor
#585308 nevow python-nevow: Python string exceptions no more allowed in Python 2.6 wishlist
#660124 nose python-nose: --no-skip broken with Python 2.7 important
#585318 pykaraoke python-pykaraoke: Python string exceptions no more allowed in Python 2.6 minor
#605170 python-axiom python-axiom: Use of PYTHONPATH env var in an insecure way important
#902759 python-http-parser python-http-parser FTBFS with Python 3.7 serious
#583875 python-tz python-tz: pytz is missing in pymodules/python2.6 normal
#734295 shiboken some shiboken tests fail with python3.4dm (debug) important
#585357 spe spe: Python string exceptions no more allowed in Python 2.6 minor
#585361 synopsis synopsis: Python string exceptions no more allowed in Python 2.6 minor