Debian Patches

Status for eclipse-wtp/3.18-6

Patch Description Author Forwarded Bugs Origin Last update
versionless.patch Donot use version in Import-Package
It fails to load as Debian is not having v3.8 of com.ibm.icu.*
Sudip Mukherjee <sudipm.mukherjee@gmail.com> not-needed
0001-528191-Replace-uses-of-org.eclipse.jface.util.Assert.patch [PATCH] [528191] Replace uses of org.eclipse.jface.util.Assert and org.eclipse.jface.text.Assert because of their deletion. Nitin Dahyabhai <thatnitind@gmail.com> no 2020-08-09
fix_jface_text.patch Use org.eclipse.core.runtime.Assert https://git.eclipse.org/c/sourceediting/webtools.sourceediting.git/commit/?id=a7ad80b1ee9a0b1ec3a730dd1010dfe24539f523 not-needed
0002-528191-Replace-uses-of-org.eclipse.jface.util.Assert.patch [PATCH] [528191] Replace uses of org.eclipse.jface.util.Assert and org.eclipse.jface.text.Assert
because of their deletion.
Nitin Dahyabhai <thatnitind@gmail.com> no 2020-08-09
ftbfs-IPluginRegistry-FTBFS.patch Replace IPluginRegistry with IExtensionRegistry not-needed debian
xerces-2.0.11-compatibility-fix.patch xerces-2.0.11-compatibility-fix
Somewhere between 2.0.9 and 2.0.11 org.apache.xerces.impl.XMLErrorReporter.reportError()
started returning String instead of void.
Jakub Adam <jakub.adam@ktknet.cz> no 2011-10-14
jflex-xmlheadtokenizer-fix.patch jflex-xmlheadtokenizer-fix Jakub Adam <jakub.adam@ktknet.cz> no 2011-12-16
jflex-compatibility.patch Fixes the compatibility with the latest version of JFlex in Debian Emmanuel Bourg <ebourg@√Ępache.org> no
build_stub.patch Build org.eclipse.perfmsr.core.stub org.eclipse.jem.util needs org.eclipse.perfmsr.core.stub ad that needs
to be built first.
not-needed
0001-Fix-license-text Fix license text (1.0 -> 2.0) no upstream, https://git.eclipse.org/c/webtools-common/webtools.common.git/commit/?id=8c4c72cb286a4e042a6ba7ec794e1a6659adf168

All known versions for source package 'eclipse-wtp'

Links