Debian Patches
Status for python-awkward/2.14.0-1
| Patch | Description | Author | Forwarded | Bugs | Origin | Last update |
|---|---|---|---|---|---|---|
| no-internet.patch | Do not try to download packages from PyPI The nox prepare target assumes that a virtual environment will be used. Therefore, it tries to install all build dependencies from pyPI before processing its build steps. This is not desired in our build environment. |
Athos Ribeiro <athos.ribeiro@canonical.com> | not-needed | debian | 2024-06-06 | |
| remove-rapidjson-license-reference.diff | Removed references to rapidjson in pyproject.html rapidjson is being installed along with python-awkward via apt and rapidjson upstream needs recursive git clone but is not needed here due to rapidjson already being installed via apt. This patch also fixes build errors for a non existent license of rapidjson. . python-awkward (2.8.9-1) unstable; urgency=medium . * Package Adoption * Updated to version 2.8.9 * Updated dependency pybind11-dev to 3.0.1 to fix C++ errors (Closes #1111956) * Remove rapidjson license reference in pyproject.toml |
Aryan Karamtoth <spaciouscoder78@disroot.org> | not-needed | 2025-09-29 | ||
| drop-importlib-metadata.diff | remove extraneous dep on python3-importlib-metadata This patch removes extraneous dep on python3-importlib-metadata . python-awkward (2.12.0-1) unstable; urgency=medium . * New upstream version 2.12.0 * Bump Standards-Version to 4.7.4 * Bump Copyright Years |
Alexandre Detiste <tchet@debian.org> | no | 2026-08-04 | ||
| scikit-build-core-version.patch | Build with the scikit-build-core available in Debian Upstream requires scikit-build-core >= 1.0, which is not packaged in Debian yet (unstable has 0.12.2). The configuration used by this package and the build itself need nothing newer than 0.12, so relax the requirement so that the package can be built. |
Andreas Tille <tille@debian.org> | not-needed | 2026-10-28 | ||
| use-python3-in-noxfile.patch | Call python3 instead of python in noxfile.py The sessions invoke "python", which only exists if a package such as python-is-python3 is installed. Call "python3" instead so that the build does not need to depend on one of the what-is-python packages. |
Andreas Tille <tille@debian.org> | not-needed | 2026-10-28 |
